Error installing streamsheet due to internal-mongo/database

this is the content of my file:

#!/usr/bin/env bash
SCRIPTPATH="( cd "(dirname “$0”)" ; pwd -P )"
cd $SCRIPTPATH
sudo docker network ls | grep streamsheets > /dev/null || sudo docker network create streamsheets
sudo rm -f /internal-mongo/data/db/mongod.lock
sudo docker-compose up

i get the following error:

  • get-streamsheets.sh: 78: cd: can’t cd to streamsheets/scripts
  • standard_init_linux.go:211: exec user process caused “exec format error”
  • das Entfernen von ‘/internal-mongo/data/db/mongod.lock’ ist nicht möglich: Datei oder Verzeichnis nicht gefunden

Hi Susanne,
Sorry for the late reply we are still looking into this issue!

I will keep you posted.

Would you mind finding out, which architecture is running on your raspi?

You would need this command:

uname -m

Hello Tizian,
this is the architecture: armv7l

i now can run the start.sh file but i get another error :rofl::joy::laughing::grin::
Starting streamsheets-internal-database …
Starting streamsheets-internal-database … done
Starting streamsheets-internal-redis … done
Starting streamsheets-internal-broker … done
Starting broker … done
Starting streamsheets-service-persistence … done
Starting 5461d1ed0b89_streamsheets-service-repository … done
Starting streamsheets-service-auth … done
Starting streamsheets-service-graphs … done
Starting streamsheets-gateway … done
Starting streamsheets-service-machines … done
Starting streamsheets-webui … done
Starting streamsheets-service-feeders … done
Attaching to streamsheets-reverseproxy, streamsheets-internal-database, streamsheets-internal-broker, broker, streamsheets-internal-redis, streamsheets-service-auth, streamsheets-service-graphs, 5461d1ed0b89_streamsheets-service-repository, streamsheets-service-persistence, streamsheets-gateway, streamsheets-webui, streamsheets-service-machines, streamsheets-service-feeders
streamsheets-reverseproxy | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-database | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-broker | WARNING: no logs are available with the ‘none’ log driver
broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-redis | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-auth | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-graphs | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-persistence | WARNING: no logs are available with the ‘none’ log driver
streamsheets-gateway | WARNING: no logs are available with the ‘none’ log driver
5461d1ed0b89_streamsheets-service-repository | WARNING: no logs are available with the ‘none’ log driver
streamsheets-webui | Listening on port 9000 (http://0.0.0.0:9000)
streamsheets-service-machines | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-feeders | WARNING: no logs are available with the ‘none’ log driver

Something like this?


This is perfect. You just started Streamsheets.
The warnings only tell you, that (which is by default) the logs are turned off.
I agree this may be misleading. I will address this in a meeting.

After seeing the above screen, go to your Browser and type: http://localhost:8081/
The login screen will appear.

Cheers

Tizian

it is working! thanks a lot for the help! :star_struck::100::tada::sparkles:

1 Like