Installation on raspberry pi fails

I followed the installation to the letter but i did run in alot of problems.
First docker did not run but i did find the issue container.io seems to have an issue so i installed containerd.io_1.2.6-1_armhf.deb and dockewr worked then i had to reinstall docker-cmpose because that failed to because of docker.
now the last step is not working
In the forum there is a picture of get-streamsheets.sh.
where in the botom it says installing streamsheets this never happens to me.

i included the screenshot any help would be appreciated.
I also tried the file on github but no success

Hi Albert,

Thank you for your message. To identify the problem can you make a screenshot of the last feedback you get of the script? Or is this screenshot of yourself? (excuse my confusion)
If the screenshot is from you, you simply have to enter “y” and press enter and the installation process will begin.

If not we have to figure out at which step the script struggles:

The script installs first docker and docker-compose. In the next step it creates the directory “cedalo” and downloads the Streamsheets installer. Now the scripts will ask if you want to start and install Streamsheets.

All steps can also be done manually. You can check out our Documentation for this.

Moreover, it would be interesting to know what kind of RaspberryPi you are using and which OS.

Cheers,

Tizian

I am using a raspberry pi 3b with stretch

And the screenshot is mine

If i press y nothing happens it seams as if the script is not in the cedalo streamsheets scrips dir

I also did all the manual commands but still the last step is not done

If you look at the pictures in the forum you will see that between press yes an the rest something is done which is missing on mine screenshot

M.v.g

Albert van Wessel

Ok, we first have to check if the installer was downloaded. It seems the folder “cedalo” was created successfully. Can you navigate into the sub-directory?

cd ~/cedalo/streamsheets/scripts/

Also, check for the content of the folder with:

ls

Is there a file “start.sh”? It should look something like this:

If yes, does the start-up-command sh start.sh work? What do you get in return?

If not, is there anything in the created folder “cedalo”?
You can check by again entering ls after having navigated in the “cedalo” folder.

I guess you already have tried re-running the command for the Streamsheets-Installer?:

sudo docker run -v ~/cedalo:/streamsheets cedalo/streamsheets-installer:1.3-rpi

If all of these fail, maybe it is because of bad docker or docker-compose versions.
Can you check and send me your versions?
docker --version
docker-compose --version

it should look kind of like this:

Screenshots of any failed command could be helpful :slight_smile:

Okee here the answers:

cedalo directory
$ ls -la
total 8
drwxr-xr-x 2 root root 4096 Sep 14 15:51 .
drwxr-xr-x 22 root root 4096 Sep 14 15:51 …

as you can see nothing it seems that the script is not doing anything the dir is completly empty
so no file start.sh is found

If i run the command sudo docker run -v ~/cedalo:/streamsheets cedalo/streamsheets-installer:1.3-rpi nothing happens for a while and then the prompt returns

:/cedalo $ docker --version
Docker version 19.03.2, build 6a30dfc

/cedalo $ docker-compose --version
docker-compose version 1.24.1, build 4667896

docker images -a
REPOSITORY TAG IMAGE ID CREATED SIZE
cedalo/streamsheets-installer 1.3-rpi fdbbe89063be 5 weeks ago 20.7MB

the script to install everything seems to have done something

and the screenshot of the failed command is already in my post because if you look at the installation example

i mean this screenshot

image
yopu can see that there are three lines missing in my screenshot

i mean the lines installing streamsheets , preparing and successfully installed streamsheet , those lines are missing in my screenshot.
The strange part is that the cedalo directory is empty so could this be an right things issue?
And as i mentioned the installation of docker on my raspberry pi failed when using your script completly and i had to do that again by hand and with the change of container.io which seemed to be the issue.
So when docker installation failed docker compse failed also so basically i had to do all the stuff manually which is fine because it is all in you documentation.
So now it all ends with this command sudo docker run -v ~/cedalo:/streamsheets cedalo/streamsheets-installer:1.3-rpi which does nothing
but when i do docker system prune -a
all the images are gone then this command shows this output

Unable to find image ‘cedalo/streamsheets-installer:1.3-rpi’ locally
1.3-rpi: Pulling from cedalo/streamsheets-installer
50e6a8f95d08: Pull complete
7610a8fbb4b4: Pull complete
41cf7ea1f6a9: Pull complete
255a708719b1: Pull complete
ed656265abdd: Pull complete
952c03bd0097: Pull complete
Digest: sha256:d3a41c2a5bdc2b61239f2a71156df38813710a743966e1bb31ac12dfea86baca
Status: Downloaded newer image for cedalo/streamsheets-installer:1.3-rpi

and then stops

i do not have any clue??

Thank you for your detailed answer!

After some testing, I could not figure out, what exactly might be the problem.
Maybe some problems with user rights, or some problems while mounting the path.

I attached a zip-file to this post. It contains the folders and files, which usually should be downloaded by the Installer. This should do the trick, while not fixing the initial problem. I will try to figure out what the reason for this might be.

Until then, download the zip-file, extract it and start Streamsheets the usual way.

sudo sh start.sh

streamsheets.zip (24.1 KB)

Thx for the swift reply i will test this evening

M.v.g

Albert van Wessel

I downloaded the script and it starts finr
all the docker images are downloaded but when everything is going to start i get an error on the first error i could not make out the reason but the process topped at Starting streamsheets-reverseproxy

i rebooted the raspberry pi and started sudo sh start.sh again .
i immediatly got to the point where everything was started again except now i did get a reason why everything stopped

it says sudo sh start.sh
Starting streamsheets-internal-broker …
Starting broker …
Starting streamsheets-internal-database …
Starting streamsheets-internal-broker … done
Starting streamsheets-reverseproxy … error
Starting streamsheets-internal-database … done
ERROR: for streamsheets-reverseproxy Cannot start service streamsheets-reverseproxy: driver failed programming external connectivity on endpoint streamsheets-reverseproxy (771164047c8b1984bb61cec233faa4219b18b4000253dbb1e0087c8127c1202c): Bind for 0.0.0.0:8081 failed: port is already allocated

ERROR: for broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)
Creating streamsheets-service-auth …
Creating streamsheets-service-repository …
Creating streamsheets-service-auth … done
Creating streamsheets-service-persistence … done
Creating streamsheets-service-repository … done

ERROR: for streamsheets-internal-redis UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-reverseproxy Cannot start service streamsheets-reverseproxy: driver failed programming external connectivity on endpoint streamsheets-reverseproxy (771164047c8b1984bb61cec233faa4219b18b4000253dbb1e0087c8127c1202c): Bind for 0.0.0.0:8081 failed: port is already allocated
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).

i checked the ports and got this :slight_smile:sudo netstat --tcp --listening --programs --numeric
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 505/lighttpd
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 622/pihole-FTL
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 476/sshd
tcp 0 0 127.0.0.1:4711 0.0.0.0:* LISTEN 622/pihole-FTL
tcp6 0 0 :::80 :::* LISTEN 505/lighttpd
tcp6 0 0 :::8082 :::* LISTEN 3889/docker-proxy
tcp6 0 0 :::53 :::* LISTEN 622/pihole-FTL
tcp6 0 0 :::22 :::* LISTEN 476/sshd
tcp6 0 0 :::8090 :::* LISTEN 4589/docker-proxy
tcp6 0 0 :::1883 :::* LISTEN 3915/docker-proxy
tcp6 0 0 ::1:4711 :::* LISTEN 622/pihole-FTL

Is it correct that all the processes are running on ipv6 ?

Any idea ??
we are getting closer i already stopped my firewall because that was causing issues also.

This is the docker images that are downloaded

docker images -a
REPOSITORY TAG IMAGE ID CREATED SIZE
eclipse-mosquitto 1.5 814e2ae4442c 4 days ago 5MB
arm32v7/redis latest 7ec7b37a1c85 5 days ago 72MB
cedalo/streamsheets-webui-personal 1.3-rpi 60b215e173a3 6 days ago 136MB
cedalo/streamsheets-service-feeders-personal 1.3-rpi f4fa2101d54a 6 days ago 192MB
cedalo/streamsheets-gateway-personal 1.3-rpi df52debda641 8 days ago 141MB
cedalo/streamsheets-service-persistence-personal 1.3-rpi 5a7bd89b9569 8 days ago 126MB
cedalo/streamsheets-service-repository-personal 1.3-rpi 73680b7d0d22 8 days ago 153MB
cedalo/streamsheets-service-graphs-personal 1.3-rpi 3c98bb981b38 8 days ago 93.6MB
cedalo/streamsheets-service-auth-personal 1.3-rpi 7aaa2bd4b901 8 days ago 128MB
cedalo/streamsheets-service-machines-personal 1.3-rpi 59de669f6b68 8 days ago 138MB
cedalo/streamsheets-installer 1.3-rpi fdbbe89063be 5 weeks ago 20.7MB
cedalo/reverseproxy 1.2-rpi 4e91f8f9e8b8 3 months ago 13.4MB
andresvidal/rpi3-mongodb3 latest fca24dc11d8c 20 months ago 366MB

this are the images that are running at the moment after i started the script

docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
e65637ffbffc cedalo/streamsheets-service-repository-personal:1.3-rpi “docker-entrypoint.s…” 6 minutes ago Up 5 minutes 0.0.0.0:8090->8090/tcp streamsheets-service-repository
351dd5183b28 cedalo/streamsheets-service-persistence-personal:1.3-rpi “docker-entrypoint.s…” 6 minutes ago Up 5 minutes streamsheets-service-persistence
bf602604a945 cedalo/streamsheets-service-auth-personal:1.3-rpi “docker-entrypoint.s…” 6 minutes ago Up 5 minutes streamsheets-service-auth
1bd88f7f1ab7 andresvidal/rpi3-mongodb3 “/docker-entrypoint.…” 28 minutes ago Up 6 minutes 27017/tcp, 28017/tcp streamsheets-internal-database
98241d38aa59 eclipse-mosquitto:1.5 “/docker-entrypoint.…” 28 minutes ago Up 6 minutes 0.0.0.0:1883->1883/tcp, 8082/tcp , 0.0.0.0:8082->8080/tcp broker
48b4e9e35e45 eclipse-mosquitto:1.5 “/docker-entrypoint.…” 28 minutes ago Up 7 minutes 1883/tcp streamsheets-internal-broker

I hope you can give me a hint

Getting closer :slight_smile:

This time it seems, that the port 8081 is already in use, even if the port is not listed.
We can try two things here:

Stop all docker container again, maybe that is a docker internal issue and we can circumvent it by restarting all:

docker stop $(docker ps -aq)

and start again.

or:

docker-compose down

If this fails, we can change the used port of the “streamsheets-reverseproxy”, which is causing you trouble.

In the same folder, where the “start.sh” file is stored, open the “docker-compose.yml”
change the ports from 8081:8081to 8084:8081. (Left is the Raspi network port, right is the docker internal network port)

I hope this will do the trick :slight_smile:

Youre right we are getting there but still some steps to set i think
a litle more backinfo
is just got my raspberry 4 with 4 gig mem installed buster did run the installation script and within 5-10 minutes everything works.
Difference offcourse cpu and mem and bs speed ( usb3 for network) but i loved to get streamsheets working on raspi 3b+ with 1 gig.
the fix with the change of the port worked reverse proxy is starting now. but i do get another error which triggerd if i had running other programs so i disabled pi-hole and the desktop ( sorry for that i did not realize i had it running to free up some memory and processing time
The error i get now is this one

sh start.sh
bcc6a21d77b7332045e70985ee10d582844225db4c42ec156857b56f1556bf2f
Creating streamsheets-reverseproxy … done
Creating broker …
Creating streamsheets-internal-database …
Creating streamsheets-internal-broker …
Creating streamsheets-internal-redis …

ERROR: for streamsheets-internal-redis UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-database UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-mongodb UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-redis UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).

I restarted docker and did a docker-compse down and stangely port 8084 was there

sudo netstat --tcp --listening --programs --numeric
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 447/lighttpd
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 563/pihole-FTL
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 411/sshd
tcp 0 0 127.0.0.1:4711 0.0.0.0:* LISTEN 563/pihole-FTL
tcp6 0 0 :::80 :::* LISTEN 447/lighttpd
tcp6 0 0 :::8084 :::* LISTEN 5292/docker-proxy
tcp6 0 0 :::53 :::* LISTEN 563/pihole-FTL
tcp6 0 0 :::22 :::* LISTEN 411/sshd
tcp6 0 0 ::1:4711 :::* LISTEN 563/pihole-FTL

i killed ipv6 and still the timeout happens .
I do not have any problem anymore with a port that is blocked

I tried to increase the time out with :COMPOSE_HTTP_TIMEOUT=150 docker-compose up

but that did not resolve
I am geting close

COMPOSE_HTTP_TIMEOUT=150 docker-compose up
Creating network “streamsheets” with driver “bridge”
Creating streamsheets-internal-redis … done
Creating broker … done
Creating streamsheets-reverseproxy … done
Creating streamsheets-internal-database … done
Creating streamsheets-internal-broker … done
Creating streamsheets-service-graphs … done
Creating streamsheets-service-auth … done
Creating streamsheets-service-repository … done
Creating streamsheets-service-persistence … done
Creating streamsheets-gateway … done
Creating streamsheets-webui … done
Creating streamsheets-service-machines … done
Creating streamsheets-service-feeders … done
Attaching to broker, streamsheets-reverseproxy, streamsheets-internal-redis, streamsheets-internal-broker, streamsheets-internal-database, streamsheets-service-auth, streamsheets-service-graphs, streamsheets-service-repository, streamsheets-service-persistence, streamsheets-gateway, streamsheets-service-machines, streamsheets-webui, streamsheets-service-feeders
broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-reverseproxy | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-redis | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-database | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-auth | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-graphs | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-repository | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-persistence | WARNING: no logs are available with the ‘none’ log driver
streamsheets-gateway | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-machines | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-feeders | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-redis exited with code 139
streamsheets-internal-database exited with code 100
streamsheets-webui | Listening on port 9000 (http://0.0.0.0:9000)

any idea

So close! :slight_smile:
I have Streamsheets running on a 3B+. So this shouldn’t be an issue.
For the time being shutting down all other applications might be a good idea.

If I see this right, we are at the state, that everything starts, but this happens:
streamsheets-internal-redis exited with code 139
streamsheets-internal-database exited with code 100

To understand the reason for this a little better, I need the logs for these services.
You can turn on the logs for each service individually in the YML file.
This can be done, by commenting out

logging:
driver: “none”

in the individual sections.

Now after the start of the “start.sh” file, the terminal will give back some logs.
Logs from the redis and the database are enough.

It would help, if you could post these here!

You mean streamsheets-internal-mongodb because i can not find streamsheets-internal-database on another location in the file?

This is in the llogs for mongodb

streamsheets-service-persistence | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-repository | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-auth | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-graphs | WARNING: no logs are available with the ‘none’ log driver
broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-reverseproxy | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-database | 2019-09-20T16:07:39.020+0000 I CONTROL
streamsheets-internal-database | 2019-09-20T16:07:39.049+0000 W CONTROL 32-bit servers don’t have journaling enabled by default. Please use --journal if you want durability.
streamsheets-internal-database | 2019-09-20T16:07:39.049+0000 I CONTROL
streamsheets-internal-database | 2019-09-20T16:07:39.426+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 32-bit host=f8c8680cab78
streamsheets-internal-database | 2019-09-20T16:07:39.427+0000 I CONTROL [initandlisten] db version v3.0.14
streamsheets-internal-database | 2019-09-20T16:07:39.427+0000 I CONTROL [initandlisten] git version: 08352afcca24bfc145240a0fac9d28b978ab77f3
streamsheets-internal-database | 2019-09-20T16:07:39.428+0000 I CONTROL [initandlisten] build info: Linux raspberrypi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l BOOST_LIB_VERSION=1_49
streamsheets-internal-database | 2019-09-20T16:07:39.428+0000 I CONTROL [initandlisten] allocator: system
streamsheets-internal-database | 2019-09-20T16:07:39.428+0000 I CONTROL [initandlisten] options: {}
streamsheets-internal-database | 2019-09-20T16:07:39.964+0000 I CONTROL [initandlisten] ** WARNING: You are running this process as the root user, which is not recommended.
streamsheets-internal-database | 2019-09-20T16:07:39.965+0000 I CONTROL [initandlisten]
streamsheets-internal-database | 2019-09-20T16:07:39.965+0000 I CONTROL [initandlisten]
streamsheets-internal-database | 2019-09-20T16:07:39.966+0000 I CONTROL [initandlisten] ** NOTE: This is a 32 bit MongoDB binary.
streamsheets-internal-database | 2019-09-20T16:07:39.966+0000 I CONTROL [initandlisten] ** 32 bit builds are limited to less than 2GB of data (or less with --journal).
streamsheets-internal-database | 2019-09-20T16:07:39.967+0000 I CONTROL [initandlisten] ** Note that journaling defaults to off for 32 bit and is currently off.
streamsheets-internal-database | 2019-09-20T16:07:39.967+0000 I CONTROL [initandlisten] ** See http://dochub.mongodb.org/core/32bit
streamsheets-internal-database | 2019-09-20T16:07:39.968+0000 I CONTROL [initandlisten]
streamsheets-internal-database | 2019-09-20T16:07:42.687+0000 I NETWORK [initandlisten] waiting for connections on port 27017

seems okay but then the raspberry hangs i will have to test agin seperatly i think logging puts to much strain on the raspberry
i will update soon

Youre right we are getting there but still some steps to set i think
a litle more backinfo
is just got my raspberry 4 with 4 gig mem installed buster did run the installation script and within 5-10 minutes everything works.
Difference offcourse cpu and mem and bs speed ( usb3 for network) but i loved to get streamsheets working on raspi 3b+ with 1 gig.
the fix with the change of the port worked reverse proxy is starting now. but i do get another error which triggerd if i had running other programs so i disabled pi-hole and the desktop ( sorry for that i did not realize i had it running to free up some memory and processing time
The error i get now is this one

sh start.sh
bcc6a21d77b7332045e70985ee10d582844225db4c42ec156857b56f1556bf2f
Creating streamsheets-reverseproxy … done
Creating broker …
Creating streamsheets-internal-database …
Creating streamsheets-internal-broker …
Creating streamsheets-internal-redis …

ERROR: for streamsheets-internal-redis UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-database UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-mongodb UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-redis UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for streamsheets-internal-broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for broker UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).

I restarted docker and did a docker-compse down and stangely port 8084 was there

sudo netstat --tcp --listening --programs --numeric
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 447/lighttpd
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 563/pihole-FTL
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 411/sshd
tcp 0 0 127.0.0.1:4711 0.0.0.0:* LISTEN 563/pihole-FTL
tcp6 0 0 :::80 :::* LISTEN 447/lighttpd
tcp6 0 0 :::8084 :::* LISTEN 5292/docker-proxy
tcp6 0 0 :::53 :::* LISTEN 563/pihole-FTL
tcp6 0 0 :::22 :::* LISTEN 411/sshd
tcp6 0 0 ::1:4711 :::* LISTEN 563/pihole-FTL

i killed ipv6 and still the timeout

Still new issues i will test with a new sd card and fresh install
i get this now

Creating streamsheets-reverseproxy … done
Creating streamsheets-internal-broker … done
Creating streamsheets-internal-redis … done
Creating streamsheets-internal-database … done
Creating broker … done
Creating streamsheets-service-auth … done
Creating streamsheets-service-persistence … done
Creating streamsheets-service-repository … done
Creating streamsheets-service-graphs … done
Creating streamsheets-gateway … done
Creating streamsheets-service-machines … done
Creating streamsheets-webui … done
Creating streamsheets-service-feeders … done
Attaching to streamsheets-internal-broker, streamsheets-reverseproxy, broker, streamsheets-internal-redis, streamsheets-internal-database, streamsheets-service-graphs, streamsheets-service-auth, streamsheets-service-persistence, streamsheets-service-repository, streamsheets-gateway, streamsheets-service-machines, streamsheets-webui, streamsheets-service-feeders
streamsheets-internal-broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-reverseproxy | WARNING: no logs are available with the ‘none’ log driver
broker | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-database | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-graphs | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-auth | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-persistence | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-repository | WARNING: no logs are available with the ‘none’ log driver
streamsheets-gateway | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-machines | WARNING: no logs are available with the ‘none’ log driver
streamsheets-webui | WARNING: no logs are available with the ‘none’ log driver
streamsheets-service-feeders | WARNING: no logs are available with the ‘none’ log driver
streamsheets-internal-redis exited with code 139
broker exited with code 1

I installed buster on a new sd and the installation did do the job everything is working now still strange.
Thanks for all the help

You are welcome. I am happy, that the new install worked.:+1:
The problem does seem to be environment related.
If you at any point find out, what this issue was let me know, so we can think about a way to prevent such.

Cheers,

Tizian